Bild: Ralf Greiner

Wenn Sie bestimmte Werte in langen Kennzahlenlisten oder Betriebswirtschaftlichen Auswertungen (BWAs) suchen und wiedergeben lassen möchten, um eine eigene Kennzahlenübersicht für Ad hoc-Analysen zu erstellen, dann ist die Formel SVERWEIS das richtige Werkzeug, das in diesem Exceltipp erklärt wird.

Es gibt vier Arten von Informationen, die Sie zum Erstellen der SVERWEIS-Syntax benötigen:

  1. Den Wert (Suchkriterium), nach dem Sie in einem anderen Blatt (im Beispiel "Daten") suchen möchten. Er wird auch als "Nachschlagewert" bezeichnet und befindet sich immer in dem Blatt, in dem Sie die Sverweisformel erstellen möchten (s. Grafik oben, Zelle B4)
  2. Den Bereich, auch Matrix genannt, in dem das Suchkriterium in der ersten Spalte der Matrix enthalten ist. In unserem Beispiel ist die Matrix im Blatt "Daten". Denken Sie daran, dass das Suchkriterium immer in der ersten Spalte der Matrix stehen muss, damit SVERWEIS ordnungsgemäß funktioniert. In unserem Beispiel ist Spalte A auch die erste Spalte unserer Matrix.
    Bild: Ralf Greiner
  3. Die Spaltennummer, auch Spaltenindex genannt, in der Spalte der Matrix, die den Rückgabewert enthält. In unserem Beispiel sind es die Spalten J bis R also Spaltenindex 10 bis 18, die uns die korrekten Kennzahlenwerte für das jeweilige Jahr wiedergeben.
  4. Am Ende können Sie WAHR angeben, wenn Sie eine ungefähre Übereinstimmung, oder FALSCH angeben, wenn Sie eine genaue Übereinstimmung des Rückgabewerts haben möchten. Ich empfehle immer FALSCH bzw 0 einzugeben, da Sie nur dann einen Ausgabewert erhalten wenn das Suchkriterium exakt gefunden wird.

Stellen Sie jetzt alle vorstehenden Informationen folgendermaßen zusammen:
=SVERWEIS(Suchkriterium B4; Matrix mit dem Suchkriterium 'Daten'!A1:R12; Spaltennummer in der Matrix mit dem Rückgabewert; 10; FALSCH für eine genaue Übereinstimmung). Das Symikolon trennt dabei die einzelnen Argumente von einander ab.

Bezogen auf unser Beispiel ergibt sich für das Jahr 2015 folgende SVERWEIS-Formel:

Bild: Ralf Greiner

Was macht die Formel SVERWEIS?

SVERWEIS durchsucht in unserem Beispiel die Matrix im Tabellenblatt "Daten" in den Zellen A1:R12 nach dem Suchkriterium "Handelsspanne", dass in Zelle B4 im Blatt "Daten Lösung" steht. Da sich die Matrix und die Zelle in der das Suchkriterium steht nie ändern soll, wenn wir diese Formel auf andere Zellen übertragen, arbeiten wir mit absoluten Bezügen ($-Zeichen) und schreiben für das Argument Suchkriterium $B$4 und für die Matrix 'Daten'!$A$1:$R$12. Ist das Suchkriterium "Handelsspanne" gefunden, geht die Formel in Spalte 12 der Matrix (Jahr 2015), da wir als Spaltenindex 12 eingegeben haben, und gibt uns als Ergebnis den Zellenwert von 54% aus. Das Suchen von bestimmten Werten in langen Kennzahlenlisten wird somit durch die Formel SVERWEIS extrem beschleunigt.

Schlagworte zum Thema:  Excel, Kennzahl

Aktuell
Meistgelesen