Die Arbeit mit Excel kommt ins Stocken, wenn Fehlerausgaben in den Zellen angezeigt werden. Die Formel WENNFEHLER kann hier schnell und einfach helfen.

Kennen Sie das? Sie haben eine Übersicht mit Umsatzzahlen, Kosten und Kennzahlen, die z.B. deren Berechnung eine Division voraussetzt. Bei Zellen ohne Wert werden die Kennzahlen dann mit dem Fehler #DIV/0! angezeigt. 

Hilfreiche Formeln bei Fehlerausgaben 

Nicht selten wird z.B. eine Deckungsbeitragsrechnung in einer Jahresübersicht nach Monaten gezeigt, um sich einen besseren Überblick zu verschaffen. Oft werden dort auch prozentuale Anteile gezeigt, die bei fehlenden Umsätzen/Kosten eine Division durch NULL vornehmen, was mathematisch nicht möglich ist. Mit der Formel WENNFEHLER können Fehlerausgaben abgefangen und durch etwas anderes ersetzt werden. Excel bietet hier auch die bekannten Formeln WENN und ISTFEHLER an, die dann verschachtelt werden, um zum gleichen Ergebnis zu kommen. Die Formel WENNFEHLER ist hier aber deutlich einfacher und schneller, ohne ein kompliziertes Verschachteln.


Fehlermeldungen

In diesem Beispiel soll auch der Deckungsbeitrag I in Prozent ausgewiesen werden und wir befinden und gerade im August, sodass noch keine Zahlen für September bis Dezember vorliegen. Die Formel in Zeile 9 ergibt sich dabei durch die Division von Deckungsbeitrag I durch Erlöse. Am Beispiel für Zelle D9 lautet die Formel wie folgt: 

=D8/D6

Das Ergebnis lautet 10,50 %, da dies der Anteil von 1.312/12.500 ist. Dies ist einfach und schnell gemacht, doch ab September (Zelle L9 - rot) gibt es Probleme, da eine Division von NULL durch NULL nicht möglich ist und die Fehlermeldung #DIV/0! angezeigt wird.

Formel WENNFEHLER: Fehlermeldung abfangen 

Mit der Formel WENNFEHLER kann dieser Fehler abgefangen und gegen eine eigene Ausgabe ersetzt werden. Die Formel besteht dabei aus zwei Argumenten:

=WENNFEHLER(Wert; Wert falls Fehler)

Der Wert ist dabei die Zahl, die geprüft werden soll. Sollte dieser Wert dann zu einem Fehler führen, soll im zweiten Argument dann die gewünschte Ausgabe greifen und in der Zelle angezeigt werden.

Am Beispiel für den Oktober in Zelle M9 entscheiden wir uns im Falle eines Fehlers für die Ausgabe 0. Sollte der Wert zu einem Fehler führen, wird anstatt von DIV/0! eine 0 ausgegeben.

=WENNFEHLER(M8/M6;0)

Am Beispiel für den November in Zelle N9 entscheiden wir uns im Falle eines Fehlers für die Ausgabe LEER. Sollte der Wert zu einem Fehler führen, wird anstatt von DIV/0! die Zelle LEER bleiben.

=WENNFEHLER(N8/N6;““)

Am Beispiel für den Dezember in Zelle O9 entscheiden wir uns im Falle eines Fehlers für die Ausgabe eines Textes (hier Text = "Fehler"). Sollte der Wert zu einem Fehler führen, wird anstatt von DIV/0! der Text ausgegeben.

=WENNFEHLER(N8/N6;“Fehler“)

Hinweis: Die Formel WENNFEHLER kann ein wichtiges Instrument sein, wenn Zellen voneinander abhängig sind. Sobald es an einer Stelle zu einem Fehler kommt, wird dieser Fehler an alle nachfolgenden Zellen, die von diesem Wert abhängig sind, weitergegeben. Dies kann in Auswertungen nachteilig sein, da bei Formeln mit dem SVERWEIS manchmal einfach noch keine Zahlen vorhanden sind und dadurch die komplette Auswertung nicht funktioniert. Hier sollte dann lieber als Fehler eine 0 ausgewiesen werden, damit nachfolgende Berechnungen fehlerfrei klappen. Wichtig bleibt jedoch, dass Fehlermeldungen einen Informationscharakter haben, die nicht immer unterdrückt werden sollten! Sonst werden echte Formelfehler nicht mehr erkannt.

Schlagworte zum Thema:  Excel