| Controllerpraxis

EXCEL-TIPP: Mittelwerte ohne Nullwerte ermitteln

Angenommen Sie haben in Excel eine Tabelle mit Vertriebszahlen, also Menge, Preis und Umsatz, und Sie möchten nun aus diesen Zahlen Mittelwerte bilden, die keine Nullwerte berücksichtigen. Dann müssen Sie mit einem kleinen Kniff arbeiten.

Sehen Sie sich zunächst einmal die Ausgangstabelle an:

Um zu Vergleichszwecken den Mittelwert mit Berücksichtigung von Nullwerten zu errechnen, müssen Sie wie folgt vorgehen:

Step by Step

1. Erfassen Sie in Zelle B16 die Formel =MITTELWERT(B4:B14).

2. Kopieren Sie dann diese Formel in Zelle D16 und sehen Sie sich das Ergebnis an. Es wird nun sowohl hinsichtlich der Menge als auch hinsichtlich des Umsatzes ein Mittelwert ausgewiesen, der die Nullwerte mit berücksichtigt.

Fahren Sie nun folgendermaßen fort, um die Mittelwerte ohne Berücksichtigung von Nullwerten auszuweisen:

Step by Step

1. Erfassen Sie in Zelle B18 die Funktion =MITTELWERT(WENN(B4:B14 <>0;B4:B14)). Schließen die Eingabe mit der Tastenkombination Strg + Umschalt + Enter ab, da es sich hierbei um eine Matrixfunktion handelt.

2. Wiederholen Sie diesen Vorgang auch für den Umsatz, d.h. in der Zelle D18, und sehen Sie sich dann das Ergebnis an. Es wurde nun ein Mittelwert gebildet ohne Berücksichtigung von Nullwerten.

Hinweis:
Um bei der Durchschnittsberechnung nur Werte größer z. B. 2.000 EUR zu berücksichtigen, müssen Sie die Formel in Zelle D18 wie folgt modifizieren: =MITTELWERT(WENN(D4:D14>2000;D4:D14)).

Aktuell

Meistgelesen